Men

Boxer ShortsMen BriefsSuits

Home

Bosch Upright Vacuum CleanersFanDehumidifierFabric SoftenersMicrowave OvenPhilips Upright Vacuum CleanersMopsBedding SetMultipurpose CookerRowenta Upright Vacuum CleanersRefrigeratorPillowsRobot Vacuum CleanerSandwich MakersVileda MopsWashing MachineXiaomi Robot Vacuum CleanerUpright Vacuum CleanersVacuum CleanerLeifheit MopsMixerRoborock Robot Vacuum Cleaner

Kids

Barbie PuppetsKids’ BikesKids SneakersLANSINOH Baby BottlesKids Stroller & PushchairKids Car SeatKids SweatsuitsBaby & Toddler ToysKids ShoesKids SandalsKids BootsPuppetsPhilips Avent Baby BottlesBaby BottlesToys

Women

Kids Polo T-ShirtsKids Watchesadidas TrousersKids SunglassesKids PajamasPandora JewelryBrasNike SocksJewelryNecklacesBlousesRingsJeansPajamasNike SweatpantsDressesBlack DressesKids EarringsNike T-ShirtsCharmsMANGO DressesShortsPolo T-ShirtsSunglassesBlack JeansSwarovski JewelrySwarovski EarringsEarringsSweatpantsSwimsuitsSweatshirtsT-ShirtsPink DressesSkirtsTriumph BrasSocksWatchesTrousersSwimsuitsWhite DressesWhite JeansWhite TrousersWhite T-ShirtsBikiniPandora EarringsPandora RingsPandora Charms

Beauty

Blue NailAvon Fragrances and DeodorantsEyelinersLip GlossesLashesNailCollagenLattafa Fragrances and DeodorantsLipsticksMascarasBeautyMakeupShampoosFragrances and DeodorantsBraun EpilatorEpilatorPhilips Epilator

Home Decor

Blue CarpetBedGray CarpetGreen CarpetChairsGray WallpaperIKEA DrapesCouchBeige CarpetBathroom FurnitureParquetPink CarpetNightstandsOffice DeskFurnitureDrapesDresserLightingPaintPaintingsChandelierRugTablesToilet SeatsWallpaperWhite CarpetWhite NightstandsWhite Wallpaper

Electronics

Apple SmartwatchesHuawei LaptopsJBL SpeakersDell LaptopsHP LaptopsLENOVO LaptopsApple LaptopsHeadphonesJBL HeadphonesHonor TelephoneMotorola TelephoneHuawei SmartwatchesSoundbarsSamsung SmartwatchesLaptopsSpeakersSamsung TelephoneSSD HarddisksSmartwatchesTabletsTelephoneXiaomi SmartwatchesXiaomi TelephoneMousePlaystation 5RouterSamsung SoundbarsTelevision

Supermarket

Barilla PastaChipsCerealsLays ChipsJacobs CoffeePastaLavAzza CoffeePistachioDavidoff CoffeeCoffeeTchibo CoffeeBulgurFortuna CoffeeConfectioneryWaterTurmeric

Shoes & Bags

Geox BootsBallerina FlatsEspadrillesLoafer ShoesBeige ShoesBootsGold-colored SandalsNike CramponsLuggageBootsBackpacksBum BagsBlack Ballerina FlatsCramponsadidas BootsBlack ShoesCasual ShoesPuma BootsCrocs AccessorySkechers SandalsSandalsShoesBeige SandalsStilettosBrown ShoesGold-colored ShoesGuess SandalsBagsTimberland BootsSandalsTommy Hilfiger SandalsWalletsWhite BootsSports ShoesUGG BootsWhite Ballerina FlatsWhite ShoesWhite Sandalsadidas SneakersSneakers

Popular Brands

ALEXANDER MCQUEENCifASOSCarrefourDecathlonDeeZeeBIOMECANICSDoTERRACoccinelleDesigualCybexcharlotte tilburyBABY BREZZAColmarBALMAINChristian DiorBalenciagaDoritosDewaltDr MartensBekoAriana GrandeAptamilElectroluxDoppelherzCartierDelonghiAntonio BanderasBuffaloBonprixAmiriAldoChanelEccoBirkenstockAppleAmdDieselBioSilAlfaparfFortunaBritney SpearsBabylissAvonBarbieBigottiBatmanCarolina HerreraDYSONASUSCrocsAlwaysBiodermaArielBepanthenDiorDellFURLADurexDunhillEmporio ArmaniGantEssenceDavid BeckhamAveneElseveBurberryDeichmannGarminGrintussGoProFarmasiFENTY BEAUTYCeraVeGAPColumbiaGolden GooseCroppCasioDJICalvin KleinGiorgio ArmaniadidasBershkaCarharttHermesHarry PotterHikvisionGucciGeoxHello KittyhokaEnglish HomeCOSGNCISABEL MARANTHonorHuggiesHuaweiHuda BeautyGivenchyHerbalifeHugoHugo BossHusqvarnaKifraGuessK18JBLHOT WHEELSKinderJumboKarcherJean Paul GaultierKarl LagerfeldIKEAKerastaseKIKOBoschL'OccitaneJuicy CoutureAsicsLaneigeLanvinLacosteJORDANLaysLancomeLinexJimmy ChooLa Roche PosayLattafaMaison MargielaLENOVOMakitaLC WaikikiLavAzzalogitechConverseEstee LauderLEGOMichelinMieleMedicubeMilwaukeeMichael KorsMomaxMonclerMilkshakeMinisoMANGOMontaleMoroccanoilMotorolaMYPROTEINMilkaMoon BootMylineMonopolyMayoralNextNespressoNokiaNutellaNutribulletNikeNintendoOppoOneplusNew BalanceMacOsteocareONLYOriflameOlaplexPalm AngelsPaco RabannePandoraPARKSIDEPaniniPampersPeppa PigPringlesRedoxonRalph LaurenRAZERRemaxPhilipsRed BullPrimarkRitualsPHILIPP PLEINRoborockPolaroidPumaRevoxSanoSanteSchweppesRoyal CaninSamsonitePradaSalomonSinsaySamsungSkullcandySeikoSol de JaneiroSkechersPentiSonicSephoraSPONGEBOBSHEINSpidermanSteve MaddenSupradynSTIHLStarbucksTakisTamagotchiStanleySwarovskiStone IslandTCLSudocremTESLATissotStradivariusTEFALTchiboTimberlandThe North FaceThe OrdinaryVera WangUGGVagabondTommy HilfigerValentinoUnder ArmourTriumphTom TailorTom FordVichyvivoVersaceVansXerjoffZzzquilVogueXiaomiYves Saint LaurentVivienne WestwoodYves Rocher

Sports & Outdoor

BicycleElectric BikeFootball JerseysElectric ScooterBasketball ProductsPoolFootballTennisTentHoverboardPilatesSkateboard

Books & Stationery

BookmarkChildren's StorybooksColored PencilsAgendaColoring BooksFolderBooksBallpoint PensPencil CasesNovelNotebooksMangaPuzzle

Chargers

8062+ item(s)
SMARTIX Premium Power Bank 5000mAh With Apple Watch Charger

SMARTIXOfficial seller badge Premium Power Bank 5000mAh With Apple Watch Charger

Lowest price in 30 days

Free shipping
Checkout Discount 13% Off

Lowest price in 30 days

-13%

112.23
AED
129
Choice White UK plug PD 45W GaN USB Charger For Phone Super Fast Charging UK ...

Choice White UK plug PD 45W GaN USB Charger For Phone Super Fast Charging UK plug Type C Charger

Free shipping
Checkout Discount 14% Off
Free shipping
Special Deals
31.27
26.89AED
Choice US Plug US Plug US Japan China Travel Plug Adapter European EU To US J...

Choice US Plug US Plug US Japan China Travel Plug Adapter European EU To US JP Power Adapter Electrical Plu

Free shipping
Checkout Discount 14% Off
Free shipping
Special Deals
12.86
11.06AED
Choice1 KR Plug Rocoren 200W GaN Charger 8 in 1 Desktop Fast Charging For iPh...

Choice KR Plug Rocoren 200W GaN Charger 8 in 1 Desktop Fast Charging For iPhone 17 Pro Xiaomi Samsung USB T

Free shipping
Checkout Discount 16% Off
Free shipping
Special Deals
106.36
89.34AED
choice2 EU Plug - 1m Cable 20W PD EU Plug Fast Wall Charger For iPhone 11 12 ...

Choice EU Plug - 1m Cable 20W PD EU Plug Fast Wall Charger For iPhone 11 12 13 mini 14 Pro Max X XR XS Max

Free shipping
Checkout Discount 11% Off
Free shipping
Special Deals
16.20
14.42AED
Choice silver 3 header 540° Degree Rotating Magnetic Wire Fast Charging PD 5A...

Choice silver 3 header 540° Degree Rotating Magnetic Wire Fast Charging PD 5A Adapter For Mobile Phone Acce

Free shipping
Checkout Discount 13% Off
Free shipping
Special Deals
18.30
15.92AED
Choice1 US 120W 4 Ports USB C Charger PD3.0 Fast Charging Type C Phone Charge...

Choice US 120W 4 Ports USB C Charger PD3.0 Fast Charging Type C Phone Charge Adapter for iPhone 17 16 Samsu

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
13.27
11.94AED
Choice 1pc B3 10W EU Plug B3 10W model aircraft lithium battery 7.4V 11.1V 2S...

Choice 1pc B3 10W EU Plug B3 10W model aircraft lithium battery 7.4V 11.1V 2S 3S simple balanced charger

Free shipping
Checkout Discount 17% Off
Free shipping
Special Deals
26.57
22.05AED
choice2 US-White 5V 2A USB Wall Fast Charger EU/US Plug Mobile Phone Quick Ch...

Choice US-White 5V 2A USB Wall Fast Charger EU/US Plug Mobile Phone Quick Charge3.0 Universal USB Power Ada

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
11.87
10.68AED
Choice Black MCP2400 USB-C Port Magnetic Charging Adapter Transfer Head Repla...

Choice Black MCP2400 USB-C Port Magnetic Charging Adapter Transfer Head Replacement For 2 Pin 4.0mm Smart W

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
12.46
11.21AED
monoprice USB Type-C Wall Charger, Power Adapter US Plug, 85W Power, Black

monoprice USB Type-C Wall Charger, Power Adapter US Plug, 85W Power, Black

Lowest price in 30 days

Free shipping
Checkout Discount 22% Off

Lowest price in 30 days

-22%

41.34
AED
53
Choice UK UK EU 30W Universal Power Adapter 3V 4.5V 5V 6V 7.5V 9V 12V AC DC C...

Choice UK UK EU 30W Universal Power Adapter 3V 4.5V 5V 6V 7.5V 9V 12V AC DC Charger Converter 5V 2.1A USB P

Free shipping
Checkout Discount 14% Off
Free shipping
Special Deals
31.03
26.69AED
choice2 US Grey USB 150W Charger 3 Ports Type C Fast Charging Mobile Phone Ch...

Choice US Grey USB 150W Charger 3 Ports Type C Fast Charging Mobile Phone Charger PD QC3.0 Adapter For iPho

Free shipping
Checkout Discount 13% Off
Free shipping
Special Deals
23.40
20.36AED
Samsung 25W Travel Adapter Without Cable - Black

Samsung 25W Travel Adapter Without Cable - Black

Lowest price in 30 days

Free shipping
Checkout Discount 9% Off

Lowest price in 30 days

-9%

86.27
AED
94.80
WIWU 18W Essen GaN Fast Charger – Wi-G006 Series

WIWU 18W Essen GaN Fast Charger – Wi-G006 Series

5.0
(1)

Lowest price in 14 days

Free shipping
Checkout Discount 21% Off

Lowest price in 14 days

-21%

27.65
AED
35
Choice KO-76 Yellow US 5 Ports Fast Charger Type C Quick Charge 3.0 USB C Wal...

Choice KO-76 Yellow US 5 Ports Fast Charger Type C Quick Charge 3.0 USB C Wall Charger Adapter For iPhone 1

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
15.06
13.55AED
Choice3 Black-US and 1MCable 120W 4 Ports USB Charger Fast Charge Phone Charg...

Choice Black-US and 1MCable 120W 4 Ports USB Charger Fast Charge Phone Charger Adapter Type C Cable For iPh

Lowest price in 14 days

Free shipping
Checkout Discount 10% Off

Lowest price in 14 days

Special Deals
12.99
11.69AED
Choice US green Elough 80W Gallium Nitride Charger Scalable Data Cable for Ip...

Choice US green Elough 80W Gallium Nitride Charger Scalable Data Cable for Iphone Huawei A+C Full Protocol

Free shipping
Checkout Discount 14% Off
Free shipping
Special Deals
29.58
25.44AED
Energizer 20000 mAh Ultimate Fast Charging PD Power Bank, Triple Outputs

EnergizerOfficial seller badge 20000 mAh Ultimate Fast Charging PD Power Bank, Triple Outputs

4.0
(1)

Lowest price in 14 days

Free shipping
Checkout Discount 13% Off

Lowest price in 14 days

-13%

164.43
AED
189
Choice1 6FT Cable Set UK USB C Charger For iPhone16 15/Huawei/Samsung QC3.0 Q...

Choice 6FT Cable Set UK USB C Charger For iPhone16 15/Huawei/Samsung QC3.0 Quick Charge PD 20W Type C Fast

Free shipping
Checkout Discount 14% Off
Free shipping
Special Deals
30.95
26.62AED
Choice3 EU Grey USB Type C 150W Charger USB QC3.0 Fast Charging Mobile Phone ...

Choice EU Grey USB Type C 150W Charger USB QC3.0 Fast Charging Mobile Phone Charger Travel Adapter For iPho

Free shipping
Checkout Discount 13% Off
Free shipping
Special Deals
24.07
20.94AED
Choice1 black 1pcs Universal EU Plug Adapter International AU UK US To EU Eur...

Choice black 1pcs Universal EU Plug Adapter International AU UK US To EU Euro KR Travel Adapter Electrical

Free shipping
Checkout Discount 11% Off
Free shipping
Special Deals
8.96
7.97AED
Aohi Magcube 67W GaN+ PD Fast USB-C Charger Block for MacBook Pro/Air,iPad Pr...

Aohi Magcube 67W GaN+ PD Fast USB-C Charger Block for MacBook Pro/Air,iPad Pro.Galaxy S22/S21, iPhone 18 Pro Max17/16/15, Amber (UK Plug)

Free shipping
Discount on cart
Free shipping

-35%

64.99
AED
99.99
Ugreen Nexode USB C Charger [GaN Tech] 30W Foldable

UgreenOfficial seller badge Nexode USB C Charger [GaN Tech] 30W Foldable

Trendyol Plus Exclusive
At checkout86.33 AED
89 AED
Choice3 EU Plug - 1.8m Cable 90W Max EU Fast Charger For Xiaomi 13 14 15 Ultr...

Choice EU Plug - 1.8m Cable 90W Max EU Fast Charger For Xiaomi 13 14 15 Ultra 15T 17 Pro Redmi Note 14 15 P

Free shipping
Checkout Discount 13% Off
Free shipping
Special Deals
26
22.62AED
Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Ch...

Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Charger For iPhone 13 11 iPad

Lowest price in 14 days

Free shipping
Coupon deal
Checkout Discount 19% Off
10% off over 10 AED

Lowest price in 14 days

-27%

25.51
AED
35
Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Ch...

Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Charger For iPhone 13 11 iPad

Lowest price in 14 days

Free shipping
Coupon deal
Checkout Discount 19% Off
10% off over 10 AED

Lowest price in 14 days

-27%

25.51
AED
35
Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Ch...

Shopi 65W Fast Charge Adapter For MacBook Pro Laptop Type C PD Quick Phone Charger For iPhone 13 11 iPad

Lowest price in 14 days

Free shipping
Coupon deal
Checkout Discount 19% Off
10% off over 10 AED

Lowest price in 14 days

-27%

25.51
AED
35
Choice US 2M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 1...

Choice US 2M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 13 12 11 Pro Max 8 Plus iPad Fa

Free shipping
Checkout Discount 12% Off
Free shipping
Special Deals
22.36
19.68AED
X.Cell Gan 2 Super Charger, 30W, Black, XL-HC-30W-1C-GAN-PD-BLK

X.CellOfficial seller badge Gan 2 Super Charger, 30W, Black, XL-HC-30W-1C-GAN-PD-BLK

Free shipping
22.40
AED
Choice11 0.25M 10A Cable 5 In 1 240w Gan Fast Charger With Led Light 2usb+3ty...

Choice 0.25M 10A Cable 5 In 1 240w Gan Fast Charger With Led Light 2usb+3type-C Multi Port Phone Charger Fo

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
8.09
7.28AED
Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-...

Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-598 RFC-690 RFC-692 RSCX-9598

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
11.03
9.93AED
ADMOS 30W Dual USB Quick Charger | 2-Port USB Wall Charger with 1m Lightning ...

ADMOS 30W Dual USB Quick Charger | 2-Port USB Wall Charger with 1m Lightning Cable for Compatible Smartphones & Devices

Lowest price in 14 days

Free shipping
20 AED coupon
Net 35% off
10% off over 10 AED
Checkout Discount 3% Off

Lowest price in 14 days

-43%

45.40
AED
80
Choice Dark Gray Charger Stand for Garmin Venu 3S & Fenix 7X Charging/ Vivoac...

Choice Dark Gray Charger Stand for Garmin Venu 3S & Fenix 7X Charging/ Vivoactive 3 4 4S Cable Dock Cord fo

4.9
(228)
Free shipping
Checkout Discount 13% Off
Free shipping
Special Deals
28.46
24.76AED
Generic Smart Auto Stop Charging Adapter with Intelligent Power Cut-Off, Univ...

Generic Smart Auto Stop Charging Adapter with Intelligent Power Cut-Off, Universal Fast Charging Safety Protector for Smartphones, Tablets and USB Devices

Free shipping
Checkout Discount 8% Off
15% off for 2+ items
Free shipping

-8%

27.60
AED
30
Choice8 UK Black 4 Port 120W USB C Fast Charger Station PD QC3.0 Wall Adapter...

Choice UK Black 4 Port 120W USB C Fast Charger Station PD QC3.0 Wall Adapter Data Cable For iPhone Samsung

Free shipping
Checkout Discount 10% Off
Free shipping
Special Deals
13.76
12.38AED
1...63...125126127128129...133...138

Promotional items

Price

Quick Charge

Reviews with images

Local delivery

Legendary November

Cross promotions

Trendyol Plus

Seller type

merchant-badges-info-tooltip-approve-seller-title
Official seller
This badge is awarded to sellers of widely recognized local and international brands.
Star seller
This badge is awarded to sellers providing high customer satisfaction and offering reliable, high-quality service over the past 6 months.
What is seller type?